La fonction NB.SI: 16 exemples d'utilisation

Dans l’article suivant de la formation Excel, vous allez découvrir 16 exemples qui expliquent comment utiliser la fonction NB.SI, et ceci selon le nombre de critère utilisé et selon son type : texte, nombre, date, valeur logique ou pour identifier des doublons dans des plages de cellules.

La fonction NB.SI


Comme nous le mentionnons toujours dans ce blog, lorsqu’une fonction comporte dans son nom le mot SI, cela signifie qu’elle sera effectuée en répondant à un ou plusieurs critères (Fonctions conditionnelles).

La fonction NB.SI permet donc de compter le nombre de cellules en répondant à un critère qui peut être une valeur textuelle, numérique, date ou logique …
La syntaxe de la fonction NB.SI est : NB.SI(plage; critères)
Pour mieux utiliser la fonction NB.SI, suivez avec moi ces différents exemples d’utilisation de cette fonction :

Utiliser la fonction NB.SI avec un seul critère

Utilisation d’un critère textuel

Voici un tableau de ventes réalisées par différents vendeurs :

Liste des vendeurs


Nous voulons par exemple compter le nombre de ventes réalisées par un vendeur sélectionné.
  • Choisissons un nom d’un vendeur comme exemple : Sergio et utilisons la fonction NB.SI pour effectuer le calcul souhaité :
  • Sélectionnez une cellule vide et tapez la formule suivante : =NB.SI(A2:A14;"Sergio")
  • Nous avons mis le nom Sergio entre guillemets puisque son type de données est texte.
Exemple de la fonction NB.SI

  • la fonction NB.SI indique donc que 3 cellules dans la plage de cellules A2:A14 qui contiennent le nom Sergio.

Résultat renvoyé par de la fonction NB.SI
  • Si vous remplacez Sergio par Sophie, vous allez obtenir 2.
Exemple 2 fonction NB.SI



Note : Vous pouvez soit entrer le nom Sophie, soit sélectionner la cellule contenant ce nom. Votre formule pourra s’écrire de deux façons alors : =NB.SI(A2:A14;"Sophie") ou =NB.SI(A2:A14;A10)
Remarquez également que la référence de cellule A10 n’est pas mise entre guillemets.

Utilisation de l’astérisque

Exemple 1 : Compter le nombre de cellules contenant des noms commençant par « S »

Sélectionnez une cellule vide et tapez la formule suivante : =NB.SI(A2:A14;"S*")
Dans cet exemple l’astérisque remplace tout ce qui vient après la lettre S, et comme vous le remarquez, Excel affiche le nombre 6.

Critère avec astérisque à la fin dans NB.SI


Exemple 2 : Compter le nombre de cellules contenant des noms qui se terminent par « a »

  • La fonction NB.SI sera écrite de la façon suivante : =NB.SI(A2:A14;"*a")
  • Ici l’astérisque remplacent tous les caractères qui se trouvent avant la lettre « a »
  • Excel affiche le nombre 3.
Critère avec astérisque au début dans NB.SI



Exemple 3 : Compter le nombre de cellules contenant un nom ou une expression…

Par exemple dans le tableau suivant, vous avez des cellules qui contiennent le nom Rico dont nous voulons compter leur nombre :
Sélectionnez une cellule vide et tapez la formule suivante : =NB.SI(A2:A14;"*rico*")
Nous avons mis donc le nom Rico entre deux astérisques parce qu’il y a des cellules où le nom complet commence par Rico et une cellule où  Rico est écrit en dernier.

Critère avec nom entre deux astérisques dans NB.SI


Note : Que vous écrivez « Rico » ou « rico » Excel renvoie le même résultat puisqu’on n’est pas obligé à respecter la casse en entrant les arguments de la fonction NB.SI.

Utilisation des opérateurs de comparaison dans les arguments de la fonction NB.SI

Exemple 1 : Egal à un nombre exact

A partir du tableau suivant vous allez calculer le nombre de personnes âgées de 33 ans:
  • Sélectionnez une cellule et entrez la fonction NB.SI comme suit : =NB.SI(B2:B14;33)
Fonction NB.SI avec critère numérique

  • Vous avez donc 4 personnes qui ont l’âge de 33 ans.

Note : Remarquez que le critère 33 est écrit sans guillemets parce que c’est un nombre et pas un texte.

Supérieur ou inférieur

Exemple 1 : Compter le nombre de cellules qui ont un montant supérieur à 1000 euros

  • Entrez la formule suivante dans une cellule : =NB.SI(C2:C14;">1000")
Critère avec operateur superieur dans NB.SI

  • Excel affiche 13 comme résultat de cette formule.

Note : Si vous avez bien remarqué, l’argument >1000 est écrit entre guillemets. Notez donc que lorsque vous insérez des nombres accompagnés des opérateurs de comparaisons vous devez toujours les mettre entre guillemets.

Exemple 2 : Compter le nombre de cellules contenant un montant inférieur à 2500 Euros

La fonction NB.SI sera utilisée de la façon suivante dans ce cas : 
=NB.SI(C2:C14;"<2500")

Critère avec operateur inférieur dans NB.SI


Utilisation de la date comme critère

Exemple 1 : Compter le nombre de cellules contenant une date précise

Dans cet exemple vous allez utiliser la fonction NB.SI pour trouver le nombre de cellules qui contiennent la date 06/04/2017 :

  • Vous pouvez donc écrire la formule suivante : =NB.SI(B2:B14;"06/04/2017")
  • Attention : Mettez le critère date entre guillemets.

NB.SI avec critère Date


Comme vous pouvez aussi taper la formule suivante en se servant de la fonction DATE
=NB.SI(B2:B14;DATE(2017;4;6))
Les arguments de la fonction DATE sont successivement Année, Mois et Jour séparés bien sûr par des points-virgules.

Integration de la fonction DATE dans NB.SI


Exemple 2 : compter le nombre de cellules contenant des dates inférieures ou égales à 05/04/2017

Entrez la fonction NB.SI suivante dans une cellule vide : 
=NB.SI(B2:B14;"<=05/04/2017")

NB.SI inférieure à une date


Exemple 3 : compter le nombre de cellules contenant des dates supérieures ou égales à 05/04/2017

Entrez la formule suivante dans une cellule vide : =NB.SI(B2:B14;">=05/04/2017")

NB.SI supérieur à une date


Exemple 4 : Compter le nombre de cellules contenant des dates inférieures à la date d’aujourd’hui de 31 jours

Utilisez donc la fonction NB.SI de cette façon en intégrant la fonction AUJOURDHUI()
=NB.SI(B2:B14;"<"&AUJOURDHUI()-31)

NB.SI avec critère inférieur à aujrdhui de 31 jours


Exemple 5 : Compter le nombre de cellules contenant des dates inférieures à la date d’aujourd’hui de 3 mois :


  • Vous pouvez tapez tout simplement : =NB.SI(B2:B14;"<"&AUJOURDHUI()-90)

NB.SI avec critère inférieur à aujrdhui de 90 jours


AUJOURDHUI()-90 : renvoie la date d’aujourd’hui moins 90 jours (équivalent à 3 mois).


  • Ou bien intégrez la fonction DATE dans la fonction NB.SI de la façon suivante et ceci en supposant que la date d’aujourd’hui est le 06/04/2017
=NB.SI(B2:B14;"<"&DATE(2017;4 ;6)-90)


  • Et si vous voulez que le calcul soit effectué automatiquement et mis à jour, entrez la formule comme suit :
=NB.SI(B2:B14;"<"&DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI())-3;JOUR(AUJOURDHUI())))

NB.SI avec critère date inférieur à 3 mois


Expliquons un peu ce qui se passe là !!!

Nous avons montré précédemment que la fonction DATE contient trois arguments : Année, Mois et Jour. Voici sa syntaxe : DATE(année;mois;jour)

Alors, pour renvoyer l’année qui correspond à la date d’aujourd’hui nous avons utilisé une autre fonction qui est ANNEE en y intégrant la fonction AUJOURDHUI() qui renvoie elle aussi la date d’aujourd’hui : 06/04/2017

La fonction ANNEE(AUJOURDHUI()) est pareille donc à : ANNEE("06/04/2017") et renvoie 2017.

Fonction ANNEE


Pour renvoyer le mois correspondant à la date d’aujourd’hui, nous avons utilisé la fonction MOIS.
La formule MOIS(AUJOURDHUI()) renvoie le mois 4 de la date actuelle 06/04/2017.

Fonction MOIS


Et puisque nous cherchons les dates inférieures à la date d’aujourd’hui de 3 mois, nous avons tapé :  MOIS(AUJOURDHUI())-3 ce qui renvoie le mois 1 (Janvier).

Fonction MOIS exemple


Il nous reste enfin de déterminer le jour de la date d’aujourd’hui, alors nous avons utilisé la fonction JOUR :    JOUR(AUJOURDHUI()) renvoie bien sûr 6

Fonction JOUR


Alors et lorsque vous ouvrez votre classeur, votre formule destinée à compter le nombre de cellules contenants des dates inférieures à la date d’aujourd’hui de 3 mois sera mise à jour automatiquement et prend en compte l’actualisation de la date d’aujourd’hui !

Utiliser la fonction NB.SI avec plusieurs critères

Exemple 1 : Compter le nombre de cellules contenant « Sophie » et « Sergio »

Si vous reprenez le premier exemple en début de cet article, vous avez vu que nous avons entré la formule NB.SI(A2:A14;"Sergio") pour compter le nombre de cellules contenant « Sergio » et la formule NB.SI(A2:A14;"Sophie") pour compter le nombre de cellules contenant « Sophie ».

Alors pour utiliser la fonction NB.SI pour trouver le nombre de cellules contenant cette fois les deux noms Sergio et Sophie, il suffit tout simplement d’additionner les résultats de ces deux formules effectuées, comme ça:

= NB.SI(A2:A14;"Sergio")+ NB.SI(A2:A14;"Sophie")

NB.SI avec plusieurs critères


Dans cet exemple vous avez utilisé deux critères, si vous voulez en ajouter un autre tapez l’opérateur d’addition et entrez la fonction NB.SI pour le nouveau critère et ainsi de suite.

Exemple 2 : Compter le nombre de montants supérieurs à 1000 euros et inférieurs à 3000 euros

Les deux formules que nous pouvons utilisées se sont:
  • =NB.SI(B2:B14;">1000") qui renvoie le nombre de montants supérieurs à 1000 Euros.
  • Et =NB.SI(B2:B14;"<3000") qui renvoie le nombre de montants inférieurs à 3000 Euros.
Nous allons donc utiliser ces deux formules dans une opération de soustraction mais avec une petite modification pour avoir un résultat correct :

Voici notre formule alors :
=NB.SI(B2:B14;">1000")-NB.SI(B2:B14;">3000")

NB.SI avec deux critères superieur et inferieur


Compter le nombre de doublons

Exemple 1 : Compter le nombre de doublons dans la même colonne

Une autre possibilité que fournit l’utilisation de la fonction NB.SI est de trouver le nombre de doublons dans une plage de cellules.

Reprenons encore notre exemple des noms de vendeurs, et essayons de trouver les noms similaires dans la plage A2:A14 en utilisant NB.SI:
  • Sélectionnez la cellule B2 et entrez la formule suivante : =NB.SI($A$2:$A$14;A2)>1
  • Si la valeur contenue dans la cellule A2 est répétée plus d’une fois dans la plage de cellules A2 :A14, Excel affichera VRAI sinon il affichera FAUX.
  • Copiez la formule dans les cellules de B2 à B14, et voici ce que vous allez obtenir :

NB.SI identifier les doublons



  • Pour calculer ensuite le nombre de cellules contenant les doublons, entrez la formule suivante :
=NB.SI(B2:B14;VRAI)

Compter nombre de doublons avec NB.SI


Note : Remarquez que la valeur logique VRAI est saisie sans guillemets.

Il y a une autre solution pour ce faire également, qui consiste à utiliser NB.SI intégrée dans la fonction SOMMEPROD.

Voici comment procéder:
  • Sélectionnez une cellule vide et entrez la formule suivante:
=SOMMEPROD((NB.SI(A2:A14;A2:A14)>1)*(A2:A14<>""))

NB.SI integrée dans SOMMEPROD pour trouver le nombre de doublons

  • Le résultat est le même : 5 doublons aussi.
Note : pour plus de détails sur l’utilisation de cette syntaxe de la fonction SOMMEPROD, visitez le lien suivant : Moyenne pondérée avec condition

Exemple 2 : Compter le nombre de doublons dans deux colonnes

Les deux colonnes A et B contiennent des noms différents, cependant il y en a quelques-uns qui sont similaires dans les deux colonnes:
  • Entrez la formule suivante pour calculer le nombre de ces doublons :
=SOMMEPROD((NB.SI(A1:A13;B1:B13)>0)*(B1:B13<>""))

Nombre de doublons dans deux colonnes

  • NB.SI(A1:A13;B1:B13)>0: l’utilisation de NB.SI dans ce cas permet de calculer le nombre de noms de la plage A1:A13 qui se répètent au moins une fois dans la plage B1:B13.
  • Et pour que le calcul s’effectue sans erreur, la plage B1:B13 ne doit pas être vide, c’est pourquoi que nous avons entré ce test logique B1:B13<>"".


SHARE

Excel Info

  • Image
  • Image
  • Image
  • Image
  • Image