La fonction SI: 7 exemples pour bien l'utiliser et bien gérer ses paramètres

L’article présent de la formation Excel explique comment utiliser la fonction SI avec des textes, des nombres et des dates à travers des exemples vous présentant des solutions à des problèmes qui peuvent survenir lors de l’utilisation incorrecte des paramètres de cette fonction.
La fonction SI


La fonction SI est une fonction conditionnelle qui fait partie des fonctions logiques, et elle est l’une des fonctions les plus populaires d’Excel, elle permet de spécifier un test logique à effectuer.

Sa syntaxe prend la forme suivante :
Si(test_logique ;[valeur_si_vrai] ;[valeur_si_faux])

A partir de cette syntaxe vous pouvez déduire que la condition que vous spécifiez dans l’argument test_logique doit renvoyer soit la valeur VRAI soit la valeur FAUX.

Alors, si la condition est respectée c’est-à-dire qu’elle renvoie la valeur VRAI, la fonction SI applique ce que vous avez introduit dans le deuxième argument [valeur_si_vrai] ,si non, c’est-à-dire que la condition n’est pas respectée et qu’elle renvoie la valeur FAUX, la fonction SI applique alors ce que vous avez spécifié dans le troisième argument : [valeur_si_faux].

Un petit exemple :

Dans la cellule A1 nous avons tapé 2017.
Et dans la cellule A2 nous avons entré la formule suivante : =SI(A1=2017;"Année en cours";"Année différente")
Notre test logique est A1=2017. C’est-à-dire que la fonction SI doit vérifier si la cellule A1 contient 2017 ou non.
Dans notre cas A1 contient 2017, ce qui est VRAI. La fonction SI applique donc ce qui est défini dans le deuxième argument : Afficher « Année en cours » dans A2.

Fonction SI exemple



  • Remplaçons maintenant 2017 par 2018.
Notre test reste le même A1=2017, mais la condition n’est pas respectée cette fois : A1 ne contient pas 2017, notre test renvoie donc FAUX. Dans ce cas la fonction SI passe au troisième argument et applique ce qui est demandé : Afficher le texte « Année différente ».

Fonction SI exemple de valeur si faux


Note : Pour vérifier si notre condition renvoie une valeur logique (VRAI ou FAUX), nous pouvons faire un test en tapant dans la cellule B1 la formule suivante : =A1=2017

Tester une valeur vrai ou faux


Que pouvez-vous spécifier comme condition dans le premier argument test_logique ?

Que votre condition spécifiée traite du texte, des nombres, des dates ou utilise des opérateurs de comparaison, ou est sous forme de formules, l’essentiel est qu’elle doit renvoyer une valeur logique (VRAI ou FAUX).

Et quelle valeur renvoie la fonction SI après avoir testé la condition spécifiée ?

Comme nous l’avons montré précédemment, l’un des deux résultats que vous avez déterminé dans l’argument valeur_si_vrai ou l’argument valeur_si_faux sera renvoyé.

Ce résultat pourra être un texte, un nombre, une date, un calcul mathématique ou un résultat d’une formule effectuée.

Les deux arguments [valeur_si_vrai] et [valeur_si_faux] sont optionnels

En revenant à la syntaxe de la fonction SI, vous remarquez que les deux arguments valeur_si_vrai et valeur_si_faux sont écrits entre deux crochets, cela signifie dans Excel que ces arguments ne sont pas obligatoires et que vous pouvez les omettre.


  • Reprenons l’exemple précédent et entrez la formule suivante dans A2
=SI(A1=2017;)

  • Dans ce cas, la fonction SI vérifie la condition spécifiée et applique seulement le premier argument, et puisque nous avons laissé cet argument vide, Excel affiche ces valeurs par défaut :
Fonction SI sans arguments

    • Si renvoie 0 si la condition est respectée ; si non elle renvoie FAUX.
Mais si vous tapez deux points-virgules =SI(A1=2017 ;;), la fonction SI renvoie toujours 0.

Fonction Si renvoie toujours 0


En effet, la fonction SI renvoie par défaut 0 comme nous l’avons vu à l’instant si la condition est remplie (en appliquant le premier argument vide) , et lorsque la condition n’est pas remplie la fonction SI va appliquer cette fois le deuxième argument, et comme il est vide à son tour, la fonction SI renvoie par défaut la valeur 0 également.

Dans la plupart des cas, les deux arguments [valeur_si_vrai] et [valeur_si_faux] sont toujours définis par les utilisateurs, pour rendre mieux compréhensibles les résultats renvoyés par la fonction SI. Sauf dans le cas où vous aimeriez par exemple que la fonction SI ne renvoie rien, pour cela faites entrer les doubles guillemets ""  dans ces arguments.

Fonction SI renvoie le vide


Examinons maintenant de près ces exemples qui suivent pour mieux comprendre l’utilisation de la fonction SI :

Fonction SI traitant des conditions textuelles

Exemple 1 : Condition portant sur un texte exact

L’exemple suivant montre l’état de traitement des dossiers: Payé, ,enregistré, en cours de traitement ...

Exemple de tableau Excel


En utilisant la fonction SI nous aimons sélectionner uniquement les dossiers qui se sont payés.

  • Nous allons donc entrer la formule suivante dans la cellule C2 : =SI(B2="Payé";"Oui";"") et nous la copierons dans les cellules de C3 à C10.
Fonction SI vec texte exact


Remarquez donc que le mot « Payé » dans le test_logique est mis entre guillemets puisque c’est du texte.
Note : la fonction SI n’oblige pas de respecter la casse en entrant le mot « Payé ». si vous l’écrivez en minuscule (payé) ou en majuscule (PAYÉ), rien ne change.

Exemple 2 : Attention aux espaces avant et après le texte !!

Si nous reprenons l’exemple précédent et nous appliquons la même formule utilisée dans cet exemple, nous pouvons avoir un résultat non désiré.

Fonction Si problème espace avant le exte



  • Remarquez par exemple les deux cellules B8 et B10, elles contiennent le mot « Payé » mais la fonction SI renvoie du vide au lieu de la valeur « Oui ».
  • Le problème vient des espaces que nous avons tapés avant le mot "Payé" dans la cellule B8 et après le mot "Payé" dans la cellule B10.
Espaces avant et après textes Excel



  • Pour résoudre ce type de problème, nous utilisons la fonction SUPPRESPACE qui permet de supprimer les espaces du texte sauf bien sûr les espaces qui se trouvent entre les mots.
  • Voici donc la nouvelle formule à entrer dans la cellule C2: 
=SI(SUPPRESPACE(B2)="Payé";"Oui";"")


  • Copions la formule dans les autres cellules de C3 à C10, et voici ce que ça donne :
Fonction SI solution probleme espaces avant texte


Exemple 3 : Condition portant sur une partie du texte

Dans cet exemple, nous désirons afficher devant les cellules contenant « CLF » la réponse Oui, ou bien afficher Non dans le cas contraire.

  • Dans la cellule B2 nous allons entrer la formule suivante :
=SI(ESTNUM(CHERCHE("CLF";A2));"Oui";"Non")

Test logique portant sur une partie du texte dans la fonction SI


Comme vous pouvez le remarquer, nous avons imbriqué deux fonctions dans la fonction SI :

  • La fonction CHERCHE qui renvoie le numéro de position de la première lettre du mot recherché si ce dernier est trouvé, si non elle renvoie une valeur d’erreur #Valeur.
Utilisation de la fonction CHERCHE

  • La fonction ESTNUM vérifie si la valeur testée est numérique ou non. Elle va donc tester la valeur renvoyée par la fonction CHERCHE, si cette valeur est un nombre, ESTNUM renvoie VRAI, si cette valeur n’est pas un nombre, ESTNUM renvoie alors FAUX.
Utilisation de la fonction ESTNUM


Après ces deux étapes, intervient la fonction SI, qui va vérifier à son tour si la valeur renvoyée enfin par la fonction ESTNUM est VRAI, dans ce cas elle affiche Oui, si non elle affiche Non.

Utiliser la fonction SI avec test logique portant sur des nombres

Exemple 1 : Calculer une prime si

Dans l’exemple suivant, nous allons calculer une prime d’un chiffre d’affaire s’il est supérieur à 10000 euros en multipliant ce chiffre d’affaire par 3%.

  • La formule qui sera utilisée est la suivante :
=SI(A2>10000;A2*3%;0)

Remarquez que le montant 10000 est écris sans guillemets parce qu’il est de type numérique.

  • En copiant la formule dans les autres cellules, nous obtiendrons le résultat suivant :
Fonction SI supérieur à un nombre


Remarquez aussi que nous avons défini dans l’argument valeur_si_vrai une formule A2*3% qui sera effectuée lorsque la condition sera remplie.

Exemple 2 : Attention ! Quantité de stock épuisée !

Dans cet exemple, nous voulons afficher un message lorsque la quantité de stock est inférieure à 50.

  • Pour cela, nous utilisons la fonction SI de la façon suivante :
=SI(A2<50;"Epuisée";"")

  • La cellule A2 contient une quantité supérieure à 50, la cellule B2 n’affiche rien donc. Et en copiant la formule dans les autres cellules nous aurons ce résultat :
Fonction SI inférieur à une valeur numérique


Fonction SI avec test logique portant sur des dates

Exemple 1 : comparaison de deux dates

Le tableau suivant comporte une liste des dates de rendez-vous différentes. Nous estimons savoir si la date d’un rendez-vous pris est écoulée ou pas encore.

  • Pour cela nous avons entré la formule suivante dans la première cellule B2 :
=SI(A2<"24/04/2017";"Date écoulée";"Date future")

  • Puis nous l’avons copiée dans les cellules qui restent.
Fonction SI problème date



  • Mais le problème c’est que notre formule nous renvoie Date écoulée même si la date du rendez-vous est inférieure à la date d’aujourd’hui (24/04/2017)
  • La cause de ce problème est que la fonction SI ne traite pas les dates contenues dans ses paramètres et écrites comme ça  « 24/04/2017 » ou comme ça 24/04/2017 comme des valeurs de type date. Elle les considère comme des chaines de texte.
  • Pour dépasser donc ce problème, vous devez convertir votre date saisie en numéro de série reconnu par Excel comme une date.
  • Par exemple le numéro de série de la date écrite sous forme de 24/04/2017 est 42849.
1) Alors, notre formule pourra s’écrire comme ça :
=SI(A2<42849;"Date écoulée";"Date future")
Voici le résultat après avoir copié la formule :

Fonction SI avec date sous forme de numéro de série


2) Nous pouvons aussi taper la date dans une autre cellule et utiliser sa référence absolue dans notre formule :
=SI(A2<$D$2;"Date écoulée";"Date future")

Fonction SI utilisant date contenue dans une cellule


Note : lorsque vous écrivez une date dans une cellule, Excel la stocke sous la forme d’un numéro de série séquentiel afin qu’elle soit utilisable dans des calculs.

3) Ou bien utiliser la fonction DATEVAL qui permet de convertir la date écrite dans le test logique en numéro de série.
Voici notre formule obtenue :
=SI(A2<DATEVAL("24/04/2017");"Date écoulée";"Date future")

Et voici le résultat donc :

Fonction SI et DATEVAL


Note : Vous devez écrire votre date entre des guillemets, si non la fonction DATEVAL renvoie une erreur de type #VALEUR !

Exemple 2 : utiliser un calcul de date dans le test logique

Par exemple, une agence a l’habitude de rappeler ses clients de leurs rendez-vous et ceci 10 jours avant la date fixée.

  • Pour cela nous allons utiliser la fonction SI pour nous renvoyer un message texte par exemple « Rappelez » lorsqu’il reste 10 jours ou moins à la date du rendez-vous.
  • Dans la cellule B2, nous allons donc taper la formule suivante :
=SI(A2-AUJOURDHUI()<=10;"Rappelez";"")

  • Nous copions ensuite la formule et voici le résultat obtenu:
Fonction SI avec fonction AUJOURDHUI


Vous pouvez améliorer la formule pour que la fonction SI affiche un message vous informant précisément du nombre de jours restés.
=SI(A2-AUJOURDHUI()<=10;"Il vous reste " &A2-AUJOURDHUI()&" jours";"")

Fonction SI calculer nombre de jours

8 cas qui expliquent comment utiliser la fonction NB.SI.ENS

L’article présent de la formation Excel vous fait découvrir comment utiliser la fonction NB.SI.ENS pour appliquer plusieurs critères aux plages de cellules. Les critères qui seront traités dans les 8 exemples d’utilisation de NB.SI.ENS qui suivent, sont de types texte, numérique, date … Cet article va vous montrer aussi comment compter le nombre de cellules non vides correctement, et comment utiliser NB.SI.ENS avec OU logique.

La fonction NB.SI.ENS


La fonction NB.SI.ENS vous permet de compter le nombre de cellules répondant à plusieurs critères de types différents : Nombre, Texte, Date, valeur logique….
La syntaxe de la fonction NB.SI.ENS est :
NB.SI.ENS(plage_critères1; critères1; [plage_critères2; critères2]…)

Les deux arguments plage_critères1 et critères1 sont obligatoires au fonctionnement de la fonction NB.SI.ENS, quant aux autres paires plages_critères/critères, elles sont facultatives.

Combien de paires plages-critères/critères pouvez-vous introduire dans la fonction NB.SI.ENS ?
  • La fonction NB.SI.ENS peut contenir jusqu’à 127 paires plages-critères/critères.

Note : la plage critères doit être insérée toujours avant le critère associé.

Pour bien comprendre comment utiliser la fonction NB.SI.ENS, veuillez suivre ces 8 exemples :
  • Partons de ce petit tableau et entamons le premier exemple :


Liste des ventes


Exemple 1 : Combien de vendeurs ont réalisé un montant de vente plus que 3000 Euros à Paris ?

  • Sélectionnez une cellule pour y insérer la formule suivante :

=NB.SI.ENS(C2:C14;"Paris";D2:D14;">3000")
Cette formule permet de sélectionner en premier les cellules contenant « Paris » dans la plage de cellules C2:C14, puis de trouver les montants supérieurs à 3000 Euros dans la plage de cellules D2:D14 et qui correspondent à ces cellules.

Fonction NB.SI.ENS


Note : pour le premier critère "Paris", il est écrit entre guillemets puisque c’est un texte. Et pour le deuxième critère ">3000", il est écrit aussi entre guillemets parce que le nombre 3000 est précédée d’un opérateur de comparaison ">".
Normalement lorsqu’un critère est de type numérique, on l’écrit sans guillemets, mais si vous lui faites accompagner <,>, = ou <> vous devez le mettre entre guillemets.

Exemple 2 : Utilisation des références de cellules dans les arguments de la fonction NB.SI.ENS

Dans cet exemple, nous avons écrit les critères Nom de ville dans la cellule F4, et le montant de vente dans F6.
Au lieu de modifier à chaque fois notre formule exemple de NB.SI.ENS, nous allons tout simplement changer les données dans ces deux cellules F4 et F6 :

  • Voici donc notre formule dynamique que nous allons utiliser :

=NB.SI.ENS(C2:C14;F4;D2:D14;">"&F6)

Utilisation de références de cellules dans NB.SI.ENS

  • Remarque n°1 : le critère nom de la ville est remplacé par la référence de cellule F4 sans guillemets.
  • Remarque n°2 : pour le critère >3000, nous avons laissé l’opérateur > entre guillemets et avons ajouté une esperluette suivie de la référence F6 sans guillemets.

Essayons maintenant de remplacer Paris par Lisbonne et remarquez que le résultat est mis à jour automatiquement :

fonction NB.SI.ENS dynamique


Note : ne mettez pas une référence de cellules entre guillemets lorsque vous l’utilisez comme critère de la fonction NB.SI.ENS.

Exemple 3 : Combiner des astérisques avec des références de cellules

Par exemple, si vous voulez compter le nombre de cellules contenant le nom Antoine qui travaille à Lisbonne, tapez la formule suivante :
=NB.SI.ENS(B2:B14;"*"&F6&"*";C2:C14;F4)

NB.SI.ENS avec critère astérisques


Vous voyez les deux esperluettes qui se sont placées avant et après la référence de cellule F6.

Exemple 3 : Compter le nombre de cellules contenant des montants entre 2000 et 4000 Euros

Dans cet exemple, vous allez traiter deux critères de type numériques et qui se trouvent dans la même colonne ou plage de cellules.
  • Commencez d’abord par donner à chaque colonne de votre tableau un nom significatif que vous allez utiliser comme référence dans les arguments de votre fonction NB.SI.ENS. ça va vous faciliter le travail !

Par exemple renommer la plage :
  • A2:A14 par Date_Vente
  • B2:B14 par Vendeurs
  • C2:C14 par Villes
  • D2:D14 par Montants.


Renomer une plage de cellules


  • Sélectionnez une cellule vide et tapez =NB.SI.ENS( puis tapez  mon  pour faire apparaître le nom de la colonne Montants.
  • Sélectionnez-le donc et continuez la saisie de votre formule pour obtenir la formule suivante :

=NB.SI.ENS(Montants;">2000";Montants;"<4000")

NB.SI.ENS avec critères numériques


Attention !
Il faut que les plages de critères utilisées dans la fonction NB.SI.ENS aient le même nombre de lignes, si non Excel retournera une erreur de type #VALEUR !.

Utilisation des critères de type date dans la fonction NB.SI.ENS

Exemple 4 : Compter le nombre de ventes réalisées entre le 05/04/2017 et le 08/04/2017

  • Sélectionnez une cellule vide et entrez la formule suivante :
=NB.SI.ENS(A2:A14;">=05/04/2017";A2:A14;"<=08/04/2017")
  • Faites attention aux guillemets !


NB.SI.ENS avec critères dates


Exemple 5: Compter le nombre de ventes réalisées à Londres entre le 05/04/2017 et aujourd’hui et ayant un montant supérieur à 2000 Euros

Notre formule va contenir donc trois plages de critères : Date de vente, Ville et Montant de vente et la fonction AUJOURDHUI() :
  • Sélectionnez une cellule vide et entrez la formule suivante :

=NB.SI.ENS(Date_Vente;">=05/04/2017";Date_Vente;"<="&AUJOURDHUI();Ville;C14;Montants;">2000")

NB.SI.ENS avec 4 critères


  • L’objectif de cet exemple est de vous présenter une fonction NB.SI.ENS contenant quatre critères.

NB.SI.ENS différent de

Exemple 6 : Compter le nombre de cellules contenant toutes les noms de villes sauf  "Paris" et dont la date de vente est postérieure ou égale à 05/04/2017

  • Entrez la formule suivante en introduisant l’opérateur <> :

=NB.SI.ENS(Ville;"<>paris";Date_Vente;">=05/04/2017")

NB.SI.ENS différent de texte


Exemple 7 : Compter le nomber des cellules non vides

Vous avez vu dans l’article: "NB, NBVAL et NBVIDE comptent le nombre de cellules différemment" comment compter le nombre de cellules non vides en utilisant la fonction NBVAL. Et pour le faire avec la fonction NB.SI.ENS, tapez la formule suivante qui va vous permettre de compter le nombre de montants de ventes réalisées à Londres en ignorant les montants non encore enregistrés :
  • Par exemple la cellule D14 est vide.

=NB.SI.ENS(Ville;"Londres";Montants;"<>"&"")

NB.SI.ENS différent de vide


  • Remarquez donc que le critère vide est exprimé par les deux guillemets ""
  • Remarquez aussi que nous avons mis une esperluette & entre l’opérateur <> et le critère vide pour que la fonction renvoie le bon résultat.

NB.SI.ENS avec OU

Vous avez sans doute constaté que tous les critères utilisés dans la fonction NB.SI.ENS sont évalués dans les exemples précédents, alors que parfois vous souhaitez que NB.SI.ENS soit effectuée en répondant à un seul caractère au moins,  tout comme l’utilisation d’un OU logique.

Pour utiliser donc la fonction NB.SI.ENS avec OU, la solution consiste à faire l’addition des fonctions NB.SI.ENS associée chacune à son critère.

Exemple 8 : Compter le nombre de cellules contenant Paris et Londres dont les montants réalisés sont supérieurs à 3000 Euros.

  • Sélectionnez une cellule vide et entrez la formule suivante :

=NB.SI.ENS(Ville;"Paris";Montants;">2000")+NB.SI.ENS(Ville;"Londres";Montants;">2000")

NB.SI.ENS avec OU


Dans cet exemple nous avons utilisé une fonction NB.SI.ENS avec le critère Paris et une autre avec le critère Londres, et les deux contiennent aussi le même critère >2000

Pour vous assurer bien de la fonctionnalité de cette formule, faites un filtre des données comme s’est illustré dans l’image animée suivante :

Filtrer des données selon deux critères avec OU logique


La fonction NB.SI.ENS et le VBA

Terminons cet article par une solution à un petit problème qui gêne beaucoup les utilisateurs de VBA Excel (surtout les novices !) lorsqu’ils veulent utiliser la fonction NB.SI.ENS dans leur code VBA.

L’erreur qu’ils commettent c’est qu’ils utilisent la nomination en français de la fonction NB.SI.ENS dans leurs codes et bien sûr ces codes ne fonctionneront pas bien.
C’est tout à fait normal car dans VBA, ils doivent taper la fonction NB.SI.ENS en anglais comme ça : COUNTIFS.


NB.SI.ENS en anglais

La fonction NB.SI: 16 exemples d'utilisation

Dans l’article suivant de la formation Excel, vous allez découvrir 16 exemples qui expliquent comment utiliser la fonction NB.SI, et ceci selon le nombre de critère utilisé et selon son type : texte, nombre, date, valeur logique ou pour identifier des doublons dans des plages de cellules.

La fonction NB.SI


Comme nous le mentionnons toujours dans ce blog, lorsqu’une fonction comporte dans son nom le mot SI, cela signifie qu’elle sera effectuée en répondant à un ou plusieurs critères (Fonctions conditionnelles).

La fonction NB.SI permet donc de compter le nombre de cellules en répondant à un critère qui peut être une valeur textuelle, numérique, date ou logique …
La syntaxe de la fonction NB.SI est : NB.SI(plage; critères)
Pour mieux utiliser la fonction NB.SI, suivez avec moi ces différents exemples d’utilisation de cette fonction :

Utiliser la fonction NB.SI avec un seul critère

Utilisation d’un critère textuel

Voici un tableau de ventes réalisées par différents vendeurs :

Liste des vendeurs


Nous voulons par exemple compter le nombre de ventes réalisées par un vendeur sélectionné.
  • Choisissons un nom d’un vendeur comme exemple : Sergio et utilisons la fonction NB.SI pour effectuer le calcul souhaité :
  • Sélectionnez une cellule vide et tapez la formule suivante : =NB.SI(A2:A14;"Sergio")
  • Nous avons mis le nom Sergio entre guillemets puisque son type de données est texte.
Exemple de la fonction NB.SI

  • la fonction NB.SI indique donc que 3 cellules dans la plage de cellules A2:A14 qui contiennent le nom Sergio.

Résultat renvoyé par de la fonction NB.SI
  • Si vous remplacez Sergio par Sophie, vous allez obtenir 2.
Exemple 2 fonction NB.SI



Note : Vous pouvez soit entrer le nom Sophie, soit sélectionner la cellule contenant ce nom. Votre formule pourra s’écrire de deux façons alors : =NB.SI(A2:A14;"Sophie") ou =NB.SI(A2:A14;A10)
Remarquez également que la référence de cellule A10 n’est pas mise entre guillemets.

Utilisation de l’astérisque

Exemple 1 : Compter le nombre de cellules contenant des noms commençant par « S »

Sélectionnez une cellule vide et tapez la formule suivante : =NB.SI(A2:A14;"S*")
Dans cet exemple l’astérisque remplace tout ce qui vient après la lettre S, et comme vous le remarquez, Excel affiche le nombre 6.

Critère avec astérisque à la fin dans NB.SI


Exemple 2 : Compter le nombre de cellules contenant des noms qui se terminent par « a »

  • La fonction NB.SI sera écrite de la façon suivante : =NB.SI(A2:A14;"*a")
  • Ici l’astérisque remplacent tous les caractères qui se trouvent avant la lettre « a »
  • Excel affiche le nombre 3.
Critère avec astérisque au début dans NB.SI



Exemple 3 : Compter le nombre de cellules contenant un nom ou une expression…

Par exemple dans le tableau suivant, vous avez des cellules qui contiennent le nom Rico dont nous voulons compter leur nombre :
Sélectionnez une cellule vide et tapez la formule suivante : =NB.SI(A2:A14;"*rico*")
Nous avons mis donc le nom Rico entre deux astérisques parce qu’il y a des cellules où le nom complet commence par Rico et une cellule où  Rico est écrit en dernier.

Critère avec nom entre deux astérisques dans NB.SI


Note : Que vous écrivez « Rico » ou « rico » Excel renvoie le même résultat puisqu’on n’est pas obligé à respecter la casse en entrant les arguments de la fonction NB.SI.

Utilisation des opérateurs de comparaison dans les arguments de la fonction NB.SI

Exemple 1 : Egal à un nombre exact

A partir du tableau suivant vous allez calculer le nombre de personnes âgées de 33 ans:
  • Sélectionnez une cellule et entrez la fonction NB.SI comme suit : =NB.SI(B2:B14;33)
Fonction NB.SI avec critère numérique

  • Vous avez donc 4 personnes qui ont l’âge de 33 ans.

Note : Remarquez que le critère 33 est écrit sans guillemets parce que c’est un nombre et pas un texte.

Supérieur ou inférieur

Exemple 1 : Compter le nombre de cellules qui ont un montant supérieur à 1000 euros

  • Entrez la formule suivante dans une cellule : =NB.SI(C2:C14;">1000")
Critère avec operateur superieur dans NB.SI

  • Excel affiche 13 comme résultat de cette formule.

Note : Si vous avez bien remarqué, l’argument >1000 est écrit entre guillemets. Notez donc que lorsque vous insérez des nombres accompagnés des opérateurs de comparaisons vous devez toujours les mettre entre guillemets.

Exemple 2 : Compter le nombre de cellules contenant un montant inférieur à 2500 Euros

La fonction NB.SI sera utilisée de la façon suivante dans ce cas : 
=NB.SI(C2:C14;"<2500")

Critère avec operateur inférieur dans NB.SI


Utilisation de la date comme critère

Exemple 1 : Compter le nombre de cellules contenant une date précise

Dans cet exemple vous allez utiliser la fonction NB.SI pour trouver le nombre de cellules qui contiennent la date 06/04/2017 :

  • Vous pouvez donc écrire la formule suivante : =NB.SI(B2:B14;"06/04/2017")
  • Attention : Mettez le critère date entre guillemets.

NB.SI avec critère Date


Comme vous pouvez aussi taper la formule suivante en se servant de la fonction DATE
=NB.SI(B2:B14;DATE(2017;4;6))
Les arguments de la fonction DATE sont successivement Année, Mois et Jour séparés bien sûr par des points-virgules.

Integration de la fonction DATE dans NB.SI


Exemple 2 : compter le nombre de cellules contenant des dates inférieures ou égales à 05/04/2017

Entrez la fonction NB.SI suivante dans une cellule vide : 
=NB.SI(B2:B14;"<=05/04/2017")

NB.SI inférieure à une date


Exemple 3 : compter le nombre de cellules contenant des dates supérieures ou égales à 05/04/2017

Entrez la formule suivante dans une cellule vide : =NB.SI(B2:B14;">=05/04/2017")

NB.SI supérieur à une date


Exemple 4 : Compter le nombre de cellules contenant des dates inférieures à la date d’aujourd’hui de 31 jours

Utilisez donc la fonction NB.SI de cette façon en intégrant la fonction AUJOURDHUI()
=NB.SI(B2:B14;"<"&AUJOURDHUI()-31)

NB.SI avec critère inférieur à aujrdhui de 31 jours


Exemple 5 : Compter le nombre de cellules contenant des dates inférieures à la date d’aujourd’hui de 3 mois :


  • Vous pouvez tapez tout simplement : =NB.SI(B2:B14;"<"&AUJOURDHUI()-90)

NB.SI avec critère inférieur à aujrdhui de 90 jours


AUJOURDHUI()-90 : renvoie la date d’aujourd’hui moins 90 jours (équivalent à 3 mois).


  • Ou bien intégrez la fonction DATE dans la fonction NB.SI de la façon suivante et ceci en supposant que la date d’aujourd’hui est le 06/04/2017
=NB.SI(B2:B14;"<"&DATE(2017;4 ;6)-90)


  • Et si vous voulez que le calcul soit effectué automatiquement et mis à jour, entrez la formule comme suit :
=NB.SI(B2:B14;"<"&DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI())-3;JOUR(AUJOURDHUI())))

NB.SI avec critère date inférieur à 3 mois


Expliquons un peu ce qui se passe là !!!

Nous avons montré précédemment que la fonction DATE contient trois arguments : Année, Mois et Jour. Voici sa syntaxe : DATE(année;mois;jour)

Alors, pour renvoyer l’année qui correspond à la date d’aujourd’hui nous avons utilisé une autre fonction qui est ANNEE en y intégrant la fonction AUJOURDHUI() qui renvoie elle aussi la date d’aujourd’hui : 06/04/2017

La fonction ANNEE(AUJOURDHUI()) est pareille donc à : ANNEE("06/04/2017") et renvoie 2017.

Fonction ANNEE


Pour renvoyer le mois correspondant à la date d’aujourd’hui, nous avons utilisé la fonction MOIS.
La formule MOIS(AUJOURDHUI()) renvoie le mois 4 de la date actuelle 06/04/2017.

Fonction MOIS


Et puisque nous cherchons les dates inférieures à la date d’aujourd’hui de 3 mois, nous avons tapé :  MOIS(AUJOURDHUI())-3 ce qui renvoie le mois 1 (Janvier).

Fonction MOIS exemple


Il nous reste enfin de déterminer le jour de la date d’aujourd’hui, alors nous avons utilisé la fonction JOUR :    JOUR(AUJOURDHUI()) renvoie bien sûr 6

Fonction JOUR


Alors et lorsque vous ouvrez votre classeur, votre formule destinée à compter le nombre de cellules contenants des dates inférieures à la date d’aujourd’hui de 3 mois sera mise à jour automatiquement et prend en compte l’actualisation de la date d’aujourd’hui !

Utiliser la fonction NB.SI avec plusieurs critères

Exemple 1 : Compter le nombre de cellules contenant « Sophie » et « Sergio »

Si vous reprenez le premier exemple en début de cet article, vous avez vu que nous avons entré la formule NB.SI(A2:A14;"Sergio") pour compter le nombre de cellules contenant « Sergio » et la formule NB.SI(A2:A14;"Sophie") pour compter le nombre de cellules contenant « Sophie ».

Alors pour utiliser la fonction NB.SI pour trouver le nombre de cellules contenant cette fois les deux noms Sergio et Sophie, il suffit tout simplement d’additionner les résultats de ces deux formules effectuées, comme ça:

= NB.SI(A2:A14;"Sergio")+ NB.SI(A2:A14;"Sophie")

NB.SI avec plusieurs critères


Dans cet exemple vous avez utilisé deux critères, si vous voulez en ajouter un autre tapez l’opérateur d’addition et entrez la fonction NB.SI pour le nouveau critère et ainsi de suite.

Exemple 2 : Compter le nombre de montants supérieurs à 1000 euros et inférieurs à 3000 euros

Les deux formules que nous pouvons utilisées se sont:
  • =NB.SI(B2:B14;">1000") qui renvoie le nombre de montants supérieurs à 1000 Euros.
  • Et =NB.SI(B2:B14;"<3000") qui renvoie le nombre de montants inférieurs à 3000 Euros.
Nous allons donc utiliser ces deux formules dans une opération de soustraction mais avec une petite modification pour avoir un résultat correct :

Voici notre formule alors :
=NB.SI(B2:B14;">1000")-NB.SI(B2:B14;">3000")

NB.SI avec deux critères superieur et inferieur


Compter le nombre de doublons

Exemple 1 : Compter le nombre de doublons dans la même colonne

Une autre possibilité que fournit l’utilisation de la fonction NB.SI est de trouver le nombre de doublons dans une plage de cellules.

Reprenons encore notre exemple des noms de vendeurs, et essayons de trouver les noms similaires dans la plage A2:A14 en utilisant NB.SI:
  • Sélectionnez la cellule B2 et entrez la formule suivante : =NB.SI($A$2:$A$14;A2)>1
  • Si la valeur contenue dans la cellule A2 est répétée plus d’une fois dans la plage de cellules A2 :A14, Excel affichera VRAI sinon il affichera FAUX.
  • Copiez la formule dans les cellules de B2 à B14, et voici ce que vous allez obtenir :

NB.SI identifier les doublons



  • Pour calculer ensuite le nombre de cellules contenant les doublons, entrez la formule suivante :
=NB.SI(B2:B14;VRAI)

Compter nombre de doublons avec NB.SI


Note : Remarquez que la valeur logique VRAI est saisie sans guillemets.

Il y a une autre solution pour ce faire également, qui consiste à utiliser NB.SI intégrée dans la fonction SOMMEPROD.

Voici comment procéder:
  • Sélectionnez une cellule vide et entrez la formule suivante:
=SOMMEPROD((NB.SI(A2:A14;A2:A14)>1)*(A2:A14<>""))

NB.SI integrée dans SOMMEPROD pour trouver le nombre de doublons

  • Le résultat est le même : 5 doublons aussi.
Note : pour plus de détails sur l’utilisation de cette syntaxe de la fonction SOMMEPROD, visitez le lien suivant : Moyenne pondérée avec condition

Exemple 2 : Compter le nombre de doublons dans deux colonnes

Les deux colonnes A et B contiennent des noms différents, cependant il y en a quelques-uns qui sont similaires dans les deux colonnes:
  • Entrez la formule suivante pour calculer le nombre de ces doublons :
=SOMMEPROD((NB.SI(A1:A13;B1:B13)>0)*(B1:B13<>""))

Nombre de doublons dans deux colonnes

  • NB.SI(A1:A13;B1:B13)>0: l’utilisation de NB.SI dans ce cas permet de calculer le nombre de noms de la plage A1:A13 qui se répètent au moins une fois dans la plage B1:B13.
  • Et pour que le calcul s’effectue sans erreur, la plage B1:B13 ne doit pas être vide, c’est pourquoi que nous avons entré ce test logique B1:B13<>"".