Formule Excel

Dans cet article de la formation Excel, vous allez découvrir ce qu’est une formule et de quoi elle se compose.
Les formules excel

Premier Exemple

Lorsque vous saisissez l’expression suivante =20+58/2 dans une cellule et vous tapez Entrée, Excel vous affichera le nombre 49 comme résultat de calcul.

Formule Excel simple


Puisque cette expression est commencée par un signe = , dans Excel, on dit que c’est une formule qui permet d’effectuer des calculs.

Cette formule exemple est composée des éléments suivants :
  • Le signe =
  • Les opérateurs + et /
  • Des constantes qui sont ici des nombres 2058 et 2.

Deuxième Exemple

Voyons l’exemple suivant maintenant :
=Somme (A2 : A5)/4

Formule utilisant la fonction SOMME


Donc c’est une formule qui commence par le signe = et qui se compose d’autres éléments :
  • Somme : est le nom de la fonction qui effectue une opération d’addition.
  • A2 : A5 : est la référence d’une plage de cellules (A2, A3, A4 et A5)
  • 4 : constante.
  • / : opérateur mathématique de division.

Comme vous le pouvez constater alors, une formule peut contenir des fonctions Excel comme Somme, Moyen, Max, Min, Si …. (Nous y reviendrons dans les articles prochains).

Troisième Exemple

Etudions ensemble l’exemple suivant :

=SI(SOMME(A2:A5)>20;"Oui";"Non")

Forume utilisant deux fonctions


Dans cet exemple, notre formule se compose de plusieurs éléments:
  • = le signe égal comme d’habitude.
  • Deux fonctions Si et Somme.
  • ( ) : deux parenthèses.
  • > : Opérateur de comparaison.
  • A2 :A5 : la référence d’une plage de cellules.
  • 20 : constante
  • "Oui" et "Non" : texte.
  • ;: deux points virgules.

Une fausse utilisation de ces éléments dans l’écriture de la formule va nous signaler une erreur d’exécution.
A partir de cet exemple, nous pouvons donc utiliser plusieurs fonctions dans une formule Excel.

Conclusion

On utilise une formule dans Excel pour effectuer des calculs ou autres actions sur des données que contient un fichier Excel.

Une formule commence toujours par un signe = suivi d’un ou plusieurs éléments, en général :
  • Fonctions : se sont des formules prédéfinies par Excel (Somme, Si, Moyen….)
  • Références : les références de cellules ou de plage de cellules. (Voir notre article sur les références des cellules).
  • Constantes : se sont des valeurs non calculées, par exemple un nombre 125, une date 20/11/2016, un texte "Total des ventes".
  • Opérateurs : comme des opérateurs arithmétiques : division /, multiplication * , addition +, soustraction -, exposant ^, pourcentage % ou des opérateurs de comparaison <, >, =, =<, >=, <>. Ou bien des opérateurs de texte : le & (et commercial).



SHARE

Excel Info

  • Image
  • Image
  • Image
  • Image
  • Image